原因:

IE浏览器不支持ES6,因此出现promise未定义的错误。

解决方案:

引用babel-polyfill插件

npm install --save babel-polyfill

main.js里引用插件

import 'babel-polyfill'